Feeds:
Posts
Comments

Posts Tagged ‘13.10’

If you’ve upgraded your Ubuntu system to 13.10 and found that you no longer have any sound, you may have noticed in your sound preferences you now only have an audio device called “Dummy Output“. And you can’t change the device to your actual sound card, as it is no longer there (in KDE’s sound preferences, it will probably be listed as a device, yet will be greyed out, meaning you can’t select it). The problem isn’t your sound card, or needing new drivers for it, but a problem with ALSA – and hopefully will be easily fixed with the info in this article.

First, you need to check that your sound card is recognised by running this command in a terminal:

sudo aplay -l

It will then list the devices it finds (in the case of the following output, it finds the built-in audio [which is disabled in the BIOS] as well as the actual sound card I use):

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: ALC883 Analog [ALC883 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: ALC883 Digital [ALC883 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: Audigy2 [SB Audigy 2 ZS [SB0360]], device 0: emu10k1 [ADC Capture/Standard PCM Playback]
card 1: Audigy2 [SB Audigy 2 ZS [SB0360]], device 2: emu10k1 efx [Multichannel Capture/PT Playback]
card 1: Audigy2 [SB Audigy 2 ZS [SB0360]], device 3: emu10k1 [Multichannel Playback]
card 1: Audigy2 [SB Audigy 2 ZS [SB0360]], device 4: p16v [p16v]

If you see something like that, then all should be well, but if you want to make sure, copy and paste this rather lengthy command into the terminal:

echo "Sound cards recognized by the system:"; lspci -nn | grep --color=none '\[04[80][13]\]'; echo "Sound cards recognized by ALSA:"; lspci -nn | grep '\[04[80][13]\]' | while read line; do lspci -nnk | grep -A 3 '\[04[80][13]\]' | grep -e 'Kernel modules: ..*' -e '\[04[80][13]\]' | grep --color=none -F "$line"; done; echo "Sound cards recognized by ALSA, and activated:"; lspci -nn | grep '\[04[80][13]\]' | while read line; do lspci -nnk | grep -A 3 '\[04[80][13]\]' | grep -e 'Kernel drivers in use: ..*' -e '\[04[80][13]\]' | grep --color=none -F "$line"; done

The output should be something like:

Sound cards recognized by the system:
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 02)
05:01.0 Multimedia audio controller [0401]: Creative Labs SB Audigy [1102:0004] (rev 04)
Sound cards recognized by ALSA:
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 02)
05:01.0 Multimedia audio controller [0401]: Creative Labs SB Audigy [1102:0004] (rev 04)
Sound cards recognized by ALSA, and activated:
00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 02)
05:01.0 Multimedia audio controller [0401]: Creative Labs SB Audigy [1102:0004] (rev 04)

Once again, everything seems fine, other than the fact you can’t enable your sound card as an audio device. Hopefully, the following command will rectify the situation:

sudo alsa force-reload

You will probably see no change until you reboot, so do so and when you login again, your sound should be back. If it isn’t, you may need to go back into the sound preferences and make the sound card the default audio device, after which all should be well.

☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻

If the problem still persists, you can try the following command which has worked for some (replace “yourusername” with your actual username):

sudo usermod -aG audio,video,pulse,pulse-access yourusername

☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻

Did this information make your day? Did it rescue you from hours of headache? Then please consider making a donation via PayPal, to buy me a donut, beer, or some fish’n’chips for my time and effort! Many thanks!

Buy Ubuntu Genius a Beer to say Thanks!

Advertisements

Read Full Post »

If you’ve upgraded your Ubuntu system only to find you don’t have permission to do pretty much anything, as I did after upgrading to 13.10, it can be pretty annoying even for an advanced user, and downright scary for a novice. The symptoms are pretty obvious, as when you go to install updates, all you get is an error message saying “This operation cannot continue since proper authorization was not provided“. And using the Shutdown button seems to do nothing, and even using a terminal command to power off might see the shutdown process halt half-way through, forcing you to use the PC’s power button.

On top of that, even mounting removable drives (or other partitions on your internal drive) ends in being told you can’t, and even trying to play a DVD ends with “Unable to access “DVDVIDEO”. Not authorized to perform operation.

While there are ways around all of these situations for more advanced users, those less experienced with Ubuntu/Linux would find it all quite daunting, and pretty much look at their system as unusable. And one shouldn’t have to go through the bother of manually mounting drives through the terminal, or invoking the Software Updater as superuser, or any other thing we usually take for granted.

Luckily, the fix – which involves PAM (Pluggable Authentication Modules) – is actually quite simple, and should have everything back to normal in no time.

In a terminal, enter the following command to edit the PAM authentication file for the LightDM display manager:

gksu gedit /etc/pam.d/lightdm

Under the first line “#%PAM-1.0” paste the following 2 lines:

session required pam_loginuid.so
session required pam_systemd.so

Save and exit the file, then log out and back in again, and all should now be fine (you shouldn’t need to reboot).

☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻

Another method, which fixed the problem for some (but not in my case, and many others) is to run:

sudo pam-auth-update --force

This opens PAM‘s config within the terminal, at which you either check or uncheck items, or just hit Tab to go to OK, and hit Enter.

☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻

If need be, like you have GDM installed and it is interfering with LightDM, run dpkg-reconfigure gdm and select lightdm (you may need to reboot).

☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻☻

Did this information make your day? Did it rescue you from hours of headache? Then please consider making a donation via PayPal, to buy me a donut, beer, or some fish’n’chips for my time and effort! Many thanks!

Buy Ubuntu Genius a Beer to say Thanks!

Read Full Post »